Increase in 500 error responses to API requests
Incident Report for Sendbird Canada
Resolved
The servers have returned operational.

[Incident Report]
When: 21:45 - 21:54 CDT August 13 (11:45 - 11:54 KST August 14; 02:45 - 02:54 GMT August 14)
Impact: Majority of API requests received 500 error responses.
Root cause: A backend service was restarted to enable new functionality, and did not properly authenticate to necessary resources on startup due to invalid logic.
Remediation:
- Immediately addressed authentication issue to successfully restore normal operations.
- Remove unnecessary logic that caused the error situation since it is not necessary
- Implement further validation and error condition handling.
Posted Aug 13, 2023 - 21:54 CDT
Investigating
We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Aug 13, 2023 - 21:45 CDT
This incident affected: Sendbird Canada server.